Mikrotik DUAL WAN Load Balancing utilizing PCC method or strategy


Mikrotik DUAL WAN Load Balancing utilizing PCC method orstrategy

Taking after is a finished script for Mikrotik to consolidate/load equalization two DSL lines. In this sample I utilized MikrotikT RB750 5 ports switch.

2 ports were joined with two distinction DSL Routers,

what's more, third port was joined with User LAN.

Both DSL are of same rate , i.e 10Mb each.

DSL MODEM IP'S

DSL MODEM 1 = 192.168.1.1

DSL MODEM 2 = 192.168.2.1

Likewise keep in mind to rename the interface names as needs be.

In my work force experience , If clients solicitation are straightforwardly hitting Mikrotik designed with PCC , then you will get great burden adjusting. Use src-address as classifier, along these lines you will dispose of issues such as https/broken connection, spilling issues and so on. Load adjusting utilizing this PCC strategy (src-location) will be viable and adjusted methodology when more associations (from customers) that happened. I additionally prescribe to utilize SQUID intermediary server alongside mikrotik , either parallel or in front or backend , for better reaction time and it will likewise build great skimming knowledge to clients.

In the event that some way or another you are not fulfilled by the src-address approach,play with the PCC-Classifier, then Try both addresses and ports as the classifier. While this will randomize things the most and in principle give you the most reasonable distribution of data transmission, BUT there is additionally a decent risk that it will break certain things like managing an account sites and a few gatherings. This is on the grounds that as a rule a HTTP solicitations will produce a few associations, so there is a chance that a few solicitations might go out an alternate course than the introductory one, and that will break secure sites. Consequently I for the most part stay with src-address for PCC load adjusting.
Copy Code:
/ip address
add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local
add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255 interface=WAN1
add address=192.168.2.2/24 network=192.168.2.0 broadcast=192.168.2.255 interface=WAN2
/ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=512 servers=8.8.8.8
/ip firewall mangle
add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn
add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2
add chain=prerouting dst-address=192.168.1.0/24 action=accept in-interface=Local
add chain=prerouting dst-address=192.168.2.0/24 action=accept in-interface=Local
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes
add chain=prerouting connection-mark=WAN1_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN1
add chain=prerouting connection-mark=WAN2_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN2
/ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_WAN1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_WAN2 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 distance=2 check-gateway=ping
/ip firewall nat
add chain=srcnat out-interface=WAN1 action=masquerade
add chain=srcnat out-interface=WAN2 action=masquerade
PCC WITH HOTSPOT (Reference)
/ip firewall nat add action=accept chain=pre-hotspot disabled=no dst-address-type=!local hotspot=auth

Post a Comment

good Work that you have done..good job keep it up
MikroTik Crack

[blogger][disqus][facebook]

Ch.Shahzad Nasir

{facebook#YOUR_SOCIAL_PROFILE_URL} {twitter#YOUR_SOCIAL_PROFILE_URL} {google-plus#YOUR_SOCIAL_PROFILE_URL} {pinterest#YOUR_SOCIAL_PROFILE_URL} {youtube#YOUR_SOCIAL_PROFILE_URL} {instagram#YOUR_SOCIAL_PROFILE_URL}

Contact Form

Name

Email *

Message *

Powered by Blogger.
Javascript DisablePlease Enable Javascript To See All Widget